1. Get the Diabetes Forum App for your phone - available on iOS and Android.
    Dismiss Notice
  2. Guest, we'd love to know what you think about the forum! Take the Diabetes Forum Survey 2020 »
    Dismiss Notice
  3. Diabetes Forum should not be used in an emergency and does not replace your healthcare professional relationship. Posts can be seen by the public.
    Dismiss Notice
  4. Guest, stay home, stay safe, save the NHS. Stay up to date with information about keeping yourself and people around you safe here and GOV.UK: Coronavirus (COVID-19). Think you have symptoms? NHS 111 service is available here.
    Dismiss Notice
Dismiss Notice
Find support, ask questions and share your experiences. Join the community »

Medtronic question on reservoir connector

Discussion in 'Insulin Pump Forum' started by Riri, Sep 25, 2014.

  1. Riri

    Riri Type 1 · Well-Known Member

    Messages:
    1,174
    Likes Received:
    510
    Trophy Points:
    153
    Hia - during my set change last night and I tried to half turn and click the connector on to the insulin reservoir after filling and it wouldn't click in like normal. Thought I'd got a faulty one so tried a second and the same thing happened. I didn't want to waste any more than I had to so I took the second and literally had to force down the little cap onto reservoir with quite some force to get it in before being able to half turn and click it. Anyone else finding this with their sets recently? (Normally it's a light push, turn and click into place)
     
    • Like Like x 2
  2. hale710

    hale710 Type 1 · Well-Known Member

    Messages:
    2,903
    Likes Received:
    1,082
    Trophy Points:
    178
    Nope all been fine here. Maybe you e got a bad batch?
     
  3. novorapidboi26

    novorapidboi26 Type 1 · Well-Known Member

    Messages:
    2,830
    Likes Received:
    1,853
    Trophy Points:
    178
    when I put mine on to the reservoir I turn it until I get some resistance between the end of the tubing and the reservoir top..............however, if I continue turning it clicks out and the resistance is gone.........

    begin a wee tad ocd I turn it again to feel it tighten.........

    I don't think mine is meant to click as such and once the pump piston has engaged with the reservoir bottom I don't think it matters.......

    I use the quick set tubing.......
     
  4. Riri

    Riri Type 1 · Well-Known Member

    Messages:
    1,174
    Likes Received:
    510
    Trophy Points:
    153
    Ta guys. Think it is a new batch I'm using. Once I'd got it in its been working perfectly fine. Just have to remember at my next change that I have to use a bit more force and not go into panic mode (like yesterday!)
     
  5. novorapidboi26

    novorapidboi26 Type 1 · Well-Known Member

    Messages:
    2,830
    Likes Received:
    1,853
    Trophy Points:
    178
    what infusion set do you use......?
     
  6. Riri

    Riri Type 1 · Well-Known Member

    Messages:
    1,174
    Likes Received:
    510
    Trophy Points:
    153
  7. novorapidboi26

    novorapidboi26 Type 1 · Well-Known Member

    Messages:
    2,830
    Likes Received:
    1,853
    Trophy Points:
    178
    different from me but from the images the reservoir connection is the same....

    and the reservoirs are the same even with the 1.8ml and 3.0ml....

    next time try turning till you feel it tighten, then stop.......:)
     
  8. Riri

    Riri Type 1 · Well-Known Member

    Messages:
    1,174
    Likes Received:
    510
    Trophy Points:
    153
    Hi it turns fine it's just getting to that point where it's meant to just cluck in before turning. That's when I'm having to press down on it - once in the half turn works fine. Might phone them to ask
     
  9. Riri

    Riri Type 1 · Well-Known Member

    Messages:
    1,174
    Likes Received:
    510
    Trophy Points:
    153
    Just made Medtronic aware of this and they confirmed that sometimes it seems that caps will be a tighter fit and there was no harm in applying more pressure to get it connected. They were excellent though. I said I was a worrier and going to Greece next week and he asked me if I would like to get some new sets from a different batch sent out with my spare pump tomorrow just for my own piece of mind. I call that fantastic customer care - well dine Medtrnoic. Also said it was good to have these things recorded in case others phone with same issue on this batch.
     
    • Like Like x 5
  10. Spiker

    Spiker Type 1 · Well-Known Member

    Messages:
    4,685
    Likes Received:
    8,439
    Trophy Points:
    178
    I've had the exact problem with the luer connectors on Animas Vibe reservoirs and sets from time to time. On one occasion I have had a slow leak from the reservoir and very random delivery because of it. One to watch for, on all makes of pump.
     
  11. Flowerpot

    Flowerpot Type 1 · Well-Known Member

    Messages:
    424
    Likes Received:
    1,362
    Trophy Points:
    158
    I have had the same problem the last couple of times I changed a set, usually like you say the connector pushes onto the reservoir easily and makes a definite click. I have had to push them on harder and haven't got a definite click. I was worried I hadn't got a proper connection but did check for any insulin leakage and there didn't appear to be any. Glad to hear you got such good customer care from Medtronic.
     
  12. donnellysdogs

    donnellysdogs Type 1 · Master

    Messages:
    13,197
    Likes Received:
    12,460
    Trophy Points:
    298
    Did you let manufacturer know? If you don't then they won't know people are having problems and they won't improve their products...
     
  13. Spiker

    Spiker Type 1 · Well-Known Member

    Messages:
    4,685
    Likes Received:
    8,439
    Trophy Points:
    178
    Yes Medtronic were advised.
     
  14. donnellysdogs

    donnellysdogs Type 1 · Master

    Messages:
    13,197
    Likes Received:
    12,460
    Trophy Points:
    298
    Sorry Spiker, I meant .. Did @Flowerpot advise the bad connector(s) to manufacturer....
     
  15. Spiker

    Spiker Type 1 · Well-Known Member

    Messages:
    4,685
    Likes Received:
    8,439
    Trophy Points:
    178
    Ah sorry DD, my bad!!!
     
    • Like Like x 2
  • Meet the Community

    Find support, connect with others, ask questions and share your experiences with people with diabetes, their carers and family.

    Did you know: 7 out of 10 people improve their understanding of diabetes within 6 months of being a Diabetes Forum member. Get the Diabetes Forum App and stay connected on iOS and Android

    Grab the app!
  • Tweet with us

  • Like us on Facebook